Apache2.4为什么启动报错Cannot load php5apache2

  • 时间:
  • 浏览:1
  • 来源:大发5分排列5_极速5分排列3

    httpd.exe -k start

  知识扩展

  

  5) 移除特定的Apache服务

二、再次冒出错误,查找处置法子。在再次冒出了Cannot load php5apache2_4.dll into server,该问題报告 后。查了其他其他,结果我的问題报告 是:

    步骤二 安装apache服务器 installed Apache services

    

  

  步骤六测试安装结果

  4) 移除有有有一个Apache服务

          具体参看http://bbs.csdn.net/topics/3903202002

    

  1. 安装/卸载Apache服务

    httpd.exe -k uninstall

  

  双击打开右下角图标,显示

  3) 重启已安装的Apache服务(迫使服务重读配置文件,适用于修改配置文件后)

  2. 管理Apache服务

  右下角显示

    先手动运行php目录下的php.exe文件,新版本可能性时要vc的支持,可能性没人安装会提示msvcr110.dll找没人,安装vc即可处置

    安装vc11相关组件,请到 http://www.microsoft.com/zh-CN/download/details.aspx?id=200679 下载

    没人报错后再去配置http.conf文件,加载php5apache2_4.dll(这个 代表的是2.4版本的appache),可能性是2.2的apache去加载2.4的支持文件,就会报错          Cannot load php5apache2_4.dll into server

    LoadModule php5_module "d:/php/php5apache2_4.dll"

    PHPIniDir "d:/php/"

    我是遇到这个 问題报告 ,用了2.2的apache去加载2.4的文件,升级了apache到2.4后,问題报告 处置

    http://www.apachelounge.com/download/  apache2.4 版本下载地址

  httpd.exe -n "MyServiceName" –t

    httpd.exe -k install -n "MyServiceName"

    httpd.exe -k stop || httpd.exe -k shutdown

  2) 停止已安装的Apache服务

  3) 指定服务配置文件的路径和名称

    编辑文件:<安装目录>\conf\httpd.conf

  FAQ

  2. 配置文件错误,问題报告 如下图示——处置方案:执行步骤三

    httpd.exe -k restart

    httpd.exe -k uninstall -n "MyServiceName"

  2) 指定要安装的服务的名称(适用于电脑上有有几个不同的Apache服务设施)

  1) 启动已安装的Apache服务

  1. 未安装服务,问題报告 如下图示——处置方案:执行步骤一、步骤二

    步骤四测试该服务的配置文件

    步骤三 修改配置文件

     最近学习php,按照书上的描述,下载好apache和php后,按照其中配置进行,结果遇到了上述问題报告 。花费了近有有有一个半小时的时间处置了上述问題报告 。现把处置问題报告 过程中想看 的法子总结如下。

  httpd.exe -k start

    httpd.exe -k install

  

    httpd.exe -k install -n "MyServiceName" -f "c:\files\my.conf"

    cd  C:\MAS\TRSMAS\win31\apache\bin

  注:若不使用特殊参数(如httpd.exe -k install),服务名称为Apache2.X,配置文件为conf\httpd.conf

  1) 安装apache服务

    httpd.exe -k install

    步骤一 Cmd打开命令行窗口,切换到apache安装目录下

  步骤五启动已安装的apache服务

    一.首先,当前在apache和php上下载的最新版本的软件多数可能性是绿色版的。否则在安装的以后,没人按照一般的下一步法子。而时要如下的法子

  http://localhost:port

   最先肯定是一定要注意版本问題报告 ,apache和php要保证全是 64位可能性x86版本的,这个 有以后容易忽略。